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Set up Unity for VR development ®) (<«

Updated: Apr 28, 2026

Learn how to set up and configure your Unity 3D development environment to build VR apps
for Meta Quest headsets. This tutorial provides setup instructions for the following
components:

o XR provider: Enables Unity to interface with Meta Quest devices and manages device
tracking, input, and rendering.

¢ Meta XR Core SDK: Provides tools and components to optimize and enhance VR
development for Meta devices.

* Meta XR Platform SDK: Enables identity management, entitlement checks, and platform
features such as matchmaking, in-app purchases, achievements, and social interactions.
Requires an App ID from the Meta Horizon Developer Dashboard (3.

* Project Setup Tool: Manages settings and dependencies for your Unity project.

If you're new to Unity development on Quest, check out the Hello World guide to create
your first VR app.

Prerequisites &

Before starting this tutorial, ensure you have the following:

Hardware requirements &
o Development machine running one of the following:
e Windows 10+ (64-bit)

¢ mac0S 10.10+ (x86 or ARM)


https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/documentation/unity/unity-tutorial-hello-vr/
https://developers.meta.com/horizon/develop/unity/
https://developers.meta.com/horizon/llmstxt/documentation/unity/unity-project-setup.md
https://developers.meta.com/horizon/
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Account requirements &

e Unity ID: Create or log.in to your Unity account (3

Step 1: Add the Android Build Support module &

Meta Quest devices run on Android OS and require the Unity Android Build Support module to
build and deploy applications. Follow the installation steps below to add the module and
required components:

1. Open Unity Hub.
2. Click Installs in the left navigation bar, which displays your Unity Editor versions.

3. If the pane is empty, click Install Editor and choose a compatible version. Meta Quest
devices require 2022.3.15f1 or later (6.1 or later recommended). Click Install to start the
installation process.

4. When complete, click Installs from the left navigation bar to confirm.
5. Next, select Manage > Add modules from the menu next to the Unity installation.
6. Select the following components and then click Install:

e Android Build Support

e OpendDK

e Android SDK & NDK Tools

Step 2: Create a Unity project &

Follow the steps below to create a new project in Unity Hub:

1. Select Projects in the left navigation bar, then click New project.

2Hub

Projects

nstalls w T D Modified T Editor version o

2. Select Unity Editor version 6.1 or later.


https://id.unity.com/
https://id.unity.com/
https://id.unity.com/
https://developers.meta.com/horizon/
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5. Click Create project.

?Hub

Projects
Installs
Learn
Resources

Licenses

Settings

New project

Templates
Select an Editor version, then choose a template to start
your project.

Editor version

& 6000.1.3f1

Search

L &

Universal 2D Universal 3D

Core

Set the build platform &

1. In the Unity Editor menu, select File > Build Profiles.

Universal 3D

This template includes the settings and assets you
need to start creating with the Universal Render
Pipeline (URP).

% Read more

Unity organization

Project name

@ Hello World

Location

C:\Users\

Use Unity Version Control

-+ Create project

2. Under Platforms, select Meta Quest and click Enable Platform. If you already installed the

profile, click the Switch Platform button.


https://developers.meta.com/horizon/
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Meta Quest

Meta Quest is currently disabled.

Enable Platform

Build Profiles

Welcome to Build Profiles.

dre stored as a
share with your

Add Build Profile

3. If prompted toinstall com.unity.xr.openxr , click Install.

Unity versions prior to 6.1

If the Meta Quest platform is absent from your version of Unity, select the Android build
platform.

For more information about Unity build profiles, see Build Configuration Overview.

Step 3: Install an XR provider plugin &

The XR provider plugin lets Unity support XR devices, including headsets. Choose the provider
that supports your project’s requirements.

The following provider plugins support Meta Quest devices:


https://developers.meta.com/horizon/documentation/unity/unity-build/
https://developers.meta.com/horizon/
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¢ Requires Unity 6 or later, Meta XR SDKs v74 or later.
¢ Oculus XR Plugin (% (deprecated)

¢ Recommended Version: 4.5.1

¢ Requires Unity 2022 or later, Meta XR SDKs v73 or earlier.

Oculus XR Plugin is deprecated

The Oculus XR Plugin is deprecated and scheduled for removal. Use the Unity OpenXR
Plugin instead.

For more information about XR vendor plugins, see XR Plugin Management for Meta Quest.

Option A: Install the Unity OpenXR Plugin &

All new projects should install the Unity OpenXR Plugin to get the benefit of the latest
features and optimizations.

To install the OpenXR provider plugin:


https://docs.unity3d.com/Packages/com.unity.xr.openxr@1.15/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.openxr@1.15/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.openxr@1.15/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.oculus@4.4/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.oculus@4.4/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.oculus@4.4/manual/index.html
https://developers.meta.com/horizon/documentation/unity/unity-xr-plugin/#unity-openxr-plugin
https://developers.meta.com/horizon/documentation/unity/unity-xr-plugin/#unity-openxr-plugin
https://developers.meta.com/horizon/documentation/unity/unity-xr-plugin/
https://developers.meta.com/horizon/
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Select XR Plug-in Management in the Project Settings window.

If XR Plug-in Management is not installed, select Install XR Plugin Management.

. In the Windows, Mac, Linux settings tab, select OpenXR.

In the Android, Meta Quest settings tab, select OpenXR.

. Close the Project Settings window.

. From the top menu of the Unity Editor, navigate to Window > Package Management >

Package Manager to open the Unity Package Manager window.

. On the left-hand navigation menu, make sure In Project is highlighted. Underneath Search in

Project, expand the Packages - Unity dropdown.

In the list of packages in the left menu, verify that there is a check mark beside OpenXR
Plugin, indicating that the package is installed.

For more information on how to setup the OpenXR Plugin, see the Unity OpenXR Plugin

Settings documentation.

Option B: Install the Oculus XR Plugin (deprecated) &

For projects built on Unity versions < 6 that use Meta XR SDKs < v74, install the Oculus XR
Plugin.

To install the Oculus XR provider plugin:

1.

0o N O o b~ W

Open any 3D project in the Unity Editor (version 2022 or 2023).

. From the top menu of the Unity Editor, navigate to Edit > Project Settings to open the

Project Settings window.

. Select XR Plug-in Management in the Project Settings window.

. If XR Plug-in Management is not installed, select Install XR Plugin Management.
. In the Windows, Mac, Linux settings tab, select Oculus.

. In the Android settings tab, select Oculus.

. Close the Project Settings window.

. From the top menu of the Unity Editor, navigate to Window > Package Management >

Package Manager to open the Unity Package Manager window.


https://developers.meta.com/horizon/documentation/unity/unity-openxr-settings/
https://developers.meta.com/horizon/documentation/unity/unity-openxr-settings/
https://developers.meta.com/horizon/
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Note: Installing an XR plugin does not download and import the Meta XR SDKs in to your
project. Make sure you add the Meta XR SDKs you need from the Unity Asset Store (7.

Step 4: Import the Meta XR Core SDK &

Meta develops and maintains several Unity SDKs for VR and extended reality (XR) app
development. If you are just getting started, add the Meta XR Core SDK (4 from the Unity

Asset Store. This SDK includes the most essential components and assets for development.
Follow these steps to add the Meta XR Core SDK to your project:

1. Go to the Meta Quest Unity Asset Store (7, and sign in using your Unity credentials.

2. Select or navigate to Meta XR Core SDK (2.

3. Click Add to My Assets to add the package to your Unity account’s assets.

4. Click Open in Unity to open the Package Manager window in the Unity Editor.
5. Enter your Unity credentials if prompted.

6. In the Package Manager window, in the upper-right side of the window, click Install to install
the SDK.

7. 1f prompted, click Enable for the Meta XR Feature Set to ensure the utilities function as
expected.

8. If Unity prompts you to restart the Unity Editor, select Restart Editor.

For more details about Meta XR packages, see Meta XR Packages reference page.

Step 5: Import the Meta XR Platform SDK &

The Meta XR Platform SDK (4 provides access to platform features essential for Meta Quest

development, including identity management, entitlement checks, and social features. You
need this SDK and an App ID to unlock features such as user authentication, matchmaking, in-
app purchases, achievements, and cloud storage.

Follow these steps to add the Meta XR Platform SDK to your project:

1. Go to the Meta XR Platform SDK (4 page on the Unity Asset Store, and sign in using your

Unity credentials.

2. Click Add to My Assets to add the package to your Unity account’s assets.


https://developers.meta.com/horizon/documentation/unity/unity-package-manager/
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/publishers/25353
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://assetstore.unity.com/packages/tools/integration/meta-xr-core-sdk-269169
https://developers.meta.com/horizon/documentation/unity/unity-package-manager/
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://assetstore.unity.com/packages/tools/integration/meta-xr-platform-sdk-262366
https://developers.meta.com/horizon/
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5. In the Package Manager window, click Install to install the SDK.

6. If Unity prompts you to restart the Unity Editor, select Restart Editor.
After installing the SDK, you need an App ID to initialize it. To get your App ID, create an app on

the Meta Horizon Developer Dashboard (7 and copy the App ID from the API page. For detailed
instructions, see Set up a platform app for Unity development.

For more details about Platform Solutions features, see Platform Solutions overview.

Step 6: Confirm OpenXR features are enabled &

You can enable and disable specific OpenXR features at build time for testing your app.

For this project, make sure you enable the following features to access them on your Meta
Quest headset:

¢ Meta XR Feature

¢ Meta XR Foveation

o Meta XR Subsampled Layout
To locate and enable these features:

1. Navigate to Project Settings > XR Plug-in Management > OpenXR and select the Android
tab.

2. Select Meta XR in the OpenXR Feature Groups section to display the list of Meta XR
features.

Step 7: Manage project dependencies using the Project Setup Tool &

The Project Setup Tool is a Unity Editor extension that quickly configures and resolves
dependency issues in Unity projects for Meta VR development. Follow the steps below to fix
dependency issues in your project:

1. Select Meta > Tools > Project Setup Tool in the Unity Editor. Alternatively, click Meta XR
Tools at the top of the Unity Editor, and select Project Setup Tool from the pop-up menu.

2. Toresolve all outstanding issues for the Android platform, click Fix All.

3. To apply all recommended settings for the Android platform, click Apply All.

Your project is now ready for Quest development.


https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/manage/
https://developers.meta.com/horizon/documentation/unity/ps-setup/
https://developers.meta.com/horizon/documentation/unity/ps-platform-intro/
https://developers.meta.com/horizon/
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Learn more &

To learn more about project setup, see the following resources:

o Setup Unity for Al-powered Meta Quest VR development: Build a complete VR game for

Meta Quest using Al-assisted development.

¢ Meta XR Packages

¢ The Project Setup Tool

¢ XR Plugin Management for Meta Quest

¢ Unity XR Plugin Management (3

e Project Configuration Overview

¢ Build Configuration Overview

e Platform Solutions overview

o Setup a platform app for Unity development

¢ Unity Manual (2

Next steps &

After you set up your Unity 3D development environment and project, see Set up your device
to learn how to connect your headset.

Did you find this page helpful?
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Want to share more detailed feedback? Let us know.
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https://developers.meta.com/horizon/documentation/unity/unity-project-configuration/
https://developers.meta.com/horizon/documentation/unity/unity-project-configuration/
https://developers.meta.com/horizon/documentation/unity/unity-tutorial-ai-vr-setup/
https://developers.meta.com/horizon/documentation/unity/unity-package-manager/
https://developers.meta.com/horizon/documentation/unity/unity-upst-overview/
https://developers.meta.com/horizon/documentation/unity/unity-xr-plugin/
https://docs.unity3d.com/Manual/XRPluginArchitecture.html
https://docs.unity3d.com/Manual/XRPluginArchitecture.html
https://docs.unity3d.com/Manual/XRPluginArchitecture.html
https://developers.meta.com/horizon/documentation/unity/unity-project-configuration/
https://developers.meta.com/horizon/documentation/unity/unity-build/
https://developers.meta.com/horizon/documentation/unity/ps-platform-intro/
https://developers.meta.com/horizon/documentation/unity/ps-setup/
https://docs.unity3d.com/Manual/
https://docs.unity3d.com/Manual/
https://docs.unity3d.com/Manual/
https://developers.meta.com/horizon/documentation/unity/unity-env-device-setup/
https://developers.meta.com/horizon/

